Javier Garrido

España Javier Garrido


Miembro desde hace 5 meses

Biografía

http://tauproject.sourceforge.net/


proyectotau aportó en Laravel vs Symfony hace 1 mes

Genial! :clap: :clap: :clap:

proyectotau aportó en Componentes Symfony en Laravel hace 1 mes

... y yo googleando en búsqueda de esta información ... y resulta que la tengo en casa !!!! Genial el aporte!!!!

PD: Por cierto, creo que podría ser de vuestro interés ésto: https://www.sitepoint.com/build-php-framework-symfony-components/

proyectotau aportó en ¿Es necesario composer.json SIEMPRE? ¿No basta con composer.lock? hace 3 meses

más info: https://github.com/composer/composer/issues/4297 https://www.engineyard.com/blog/composer-its-all-about-the-lock-file

proyectotau aportó en ¿Es necesario composer.json SIEMPRE? ¿No basta con composer.lock? hace 3 meses

... y una pre-view antes de publicar? ;-)

proyectotau aportó en ¿Es necesario composer.json SIEMPRE? ¿No basta con composer.lock? hace 3 meses

Hmm @italomoralesf gracias de nuevo por tus comentarios pero en aras de una mayor comprensión de la herramienta Composer considera el caso de @juankstylez y este thread:

https://github.com/composer/composer/issues/4297

Me parece que no somos los únicos!!

Para mi "desgracia" no comprendo el motivo: note that composer.lock alone is not enough to perform the full installation. The composer.json is still needed to get info about the root package, as they don't get duplicated into the composer.lock

PD: Siento que para ser un buen profesional deberíamos de conocer todos los efectos colaterales de las herramientas

proyectotau aportó en ¿Es necesario composer.json SIEMPRE? ¿No basta con composer.lock? hace 3 meses

De acuerdo, pero si yo instalé la 5.5.0, porque era ésa la que había en ese momento, y otro hace install un tiempo después, sí podría llegar a descargar, digamos, la 5.5.9 y podría haber algún problema con los test... [¿que pasaría si consideramos las versiones 5.* inicialmente?]

En cualquier caso, su entorno no coincidiría con el mío, que es de lo que se trata, no? Ése era el objetivo del .lock... no?

Gracias por toda tu ayuda !!!!

proyectotau aportó en ¿Es necesario composer.json SIEMPRE? ¿No basta con composer.lock? hace 3 meses

Mi tensión es commit a git solo composer.lock para que la instalación coincida con la que he fijado en mi composer.json, pero no el propio composer.json que está en .gitignore

De esa forma nadie podría hacer un composer update, sólo yo que tengo el composer.json en mi branch local.

Pero observo que composer no funciona del modo que suponía...

Parece que sin el fichero composer.json SIEMPRE es necesario para instalar las dependencias, sin embargo, si alguien hace update en lugar de install estaría descargando las versiones más recientes y no las versiones con las que hice el último test...

PD: De hecho, si .lock no existe (y sí .json) update son install equivalentes. De nuevo, descargaría las últimas versiones y no las últimas que usé yo...