Problemas para instalar laravel en ubuntu 18.04

Publicado hace 1 semana por @4940e1b869998bb469344a238f4389a7

Buenas, no estaria seguro si es el mejor lugar para preguntar, pero voy a tratar de ser claro, en la terminal de linux me baje el composer con: sudo apt-get install composer despues quise instalar laravel con la siguiente linea: composer global require "laravel/installer" y recibo este error:

PHP Warning: require(Composer/autoload.php): failed to open stream: No such file or directory in /usr/bin/composer on line 8 PHP Fatal error: require(): Failed opening required 'Composer/autoload.php' (include_path=':/usr/share/kopano/php') in /usr/bin/composer on line 8 solia decirme otra cosa antes, algo asi como que no encontraba una version estable de laravel, supuse que era porque tenia php 7.2.5 e intente bajar a la 7.1 pero cuando quise instalar las dependencias de este no me encontró nada. Agradeceria alguien que sepa iluminarme en el tema, Gracias